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1. Download the Demographics and Early Childhood Template, Tips Sheet, and Steps for 

Creating and Uploading Demographics and Early Childhood Data 

a. Located on the SIS Website – https://www.isbe.net/Pages/Student-Information-

System.aspx 

b. In the Other Resources box (Left side of page) → click on SIS Excel Templates → click 

on Demographic and Enrollment 

c. Save the files to a computer or server with a right Click and performing either a ‘Save 

As’ or ‘Save Target As’ 

i) Save the Student Demographics and Early Childhood Excel Template to your 

computer/server before opening it in Excel. 

ii) Save the Tips for Completing the Demographics and Early Childhood Template PDF 

document to your computer before opening it with Adobe. 

iii) Save the Steps for Creating and Uploading the Demographics and Early Childhood 

Data PDF document to your computer before opening it with Adobe. 

 

2. Authorized user must request the Demographics and Early Childhood.csv file from 

IWAS/SIS/Request File screen. 

a. Authorized user must login to IWAS. 

b. Access SIS from the System Listing. 

c. Click the Request File link in the Batch Files menu. 

d. Select the Demographics and Early Childhood option from the drop down.  

e. Click the Request File button to submit your request for your school/district’s file.  

 

3. Create the Demographics and Early Childhood.csv File Header in Row 1 Columns B, C, 

D & E 

a. Open the Demographics and Early Childhood Template. 

b. Enter the number of student records being submitted in Row 1 Column B. 

c. Enter the name of the file plus .csv in Row 1 Column C (Ex: Riverton HS.csv). 

 

 Note: This exact same name must be entered in the “SAVE AS” File name field when 

creating the CSV file later in the process. 

 

d. Enter the date the .csv file is to be uploaded to IWAS/SIS in Row 1 Column D in the 

mm/dd/yyyy format (Ex: 09/05/2020). 

e. Enter your district/school’s 15-digit RCDTS code in Row 1 Column E. 

 

 Note: This is the RCDTS assigned to your IWAS account. This can be verified via your 

IWAS profile.  

 

4. Enter the student’s Demographic (including Program Indicators), Enrollment and 

Early Childhood Data in the Excel Template 

a. Starting with Row 3 enter all mandatory data (see the Tips Sheet for mandatory fields) 

and, when available, enter the optional data for each student record. 

b. Enter the student’s unique 9-digit State Student ID (SID) in Column A. 

i) If the student has not been assigned a SID by SIS, leave the field blank and the 

system will generate a unique ID for the new student. 

https://www.isbe.net/Pages/Student-Information-System.aspx
https://www.isbe.net/Pages/Student-Information-System.aspx
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ii) If the student has a SID, include the ID to prevent creating a duplicate record. 

c. If applicable, enter your local SAP ID (up to 50 digits). 

d. Enter the student’s Legal Last Name and Legal First Name. 

e. Enter the student’s Legal Middle Name. 

i) If the student’s full middle name is unknown, use an initial without a period. 

ii) If the student does not have a legal middle name, enter an asterisk (*) in the field. 

f. Enter the following dates in the mm/dd/yyyy format (Ex: 09/05/2020): 

i) Birth Date 

ii) Enrollment Date 

g. If known, enter the Mother’s Maiden Name (last name only) and the Birth Place Name 

without periods, commas, or apostrophes. 

h. For the following data elements, use the correct codes from the Student Demographics, 

Enrollment, and Program Indicators data elements documents located on the SIS 

Website (Other Resources → Data Elements and Validations → Demographics / 

Enrollment): 

i) Enter 2-digit codes for the following data values: 

1. Lineage Code 

2. Race Code 

3. Gender Code 

4. Reading 1st Indicator 

5. Reading Improvement Block Grant Indicator  

6. Title 1 Indicator 

7. Eligible for Immigrant Education Program (Can no longer be updated 

07/31/2014) 

8. Homeless Indicator 

9. Migrant Indicator (Can no longer be updated 07/31/2014) 

10. Private School Student  

11. Military Connected Student 

12. SES Indicator  

13. EL Indicator 

14. IDEA Services 

15. Alternate Assessment Indicator 

16. Dual Language 

17. FRL/Low Income Indicator 

18. 21st Century Indicator 

19. Enrollment Type 

20. Entry/ Grade Level 

21. Tuition In 

ii) Enter 3-digit code for the following data value: 

1. Home Language 

2. Native Language 

3. Language of Instruction* 

*Optional unless Dual Language is 01 – Two Way Immersion, or 02 – One Way 

Immersion. 

iii) Enter the student’s 15-digit RCDTS codes  
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1. The Home School code will have the same first 11 district code digits and the last 

4 digits may differ to identify the school building. 

2. The Serving School code will either be the same as the Home School code if the 

student attends that school for educational services, or the Serving School will be 

different than the Home School code if the student attends a different school for 

educational services (such as a Special Ed cooperative or a vocation education 

facility). 

iv) Enter the 4-digit school year (2021 represents the 2020-2021 school year). 

v) Enter the appropriate decimal value up to 1.00 for the Serving School Percent of Day 

Attended (PDA) 

1. A student’s PDA cannot exceed a total value of 1.00 at one time in ISBE SIS. 

2. If a student attends multiple schools for educational services, multiple Home 

School enrollment records with different Serving Schools must be created with 

the PDA representing the amount of time the student spends at each Serving 

School (e.g., 0.50 PDA for time spent at a Special Education facility and 0.50 for 

time spent at a mainstream facility). 

i. For the following data elements, use the correct codes from the Early Childhood data 

elements document located on the SIS Website (Other Resources → Data Elements and 

Validations → Early Learning): 

i) Enter 2-digit codes for the following data values: 

1. Early Head Start (Birth to 3)  

2. Licensed Child Care 

3. Student’s Receiving CCAP Subsidy 

4. Meets At Risk Criteria 

5. Family Structure 

6. Household Income Criteria 

7. Child Welfare Involvement Within the Past Year 

8. Family has an Open Intact Family Services Case 

9. Child’s Parent is a Youth in Care 

10. Student’s Family is Receiving TANF 

11. Student’s Family is Receiving WIC 

12. Student’s Family is Receiving SNAP 

13. Student’s Family is Receiving a Housing Subsidy 

 

5. Save the Demographics and Early Childhood Template as a Comma-Separated Values 

(.csv) File 

a. First, save an Excel version (.xls extension) of the document as a backup with the student 

record details just entered and to use as a working document . 

b. Then create a .csv file by navigating to the File menu and click File → Save As 

c. In the File name: box, type the same file name you entered in the Header Row 1 Column 

C, excluding the ‘.csv’ extension. (Ex: for Riverton.csv, only type Riverton). 

d. Look at the Save in: and either take note of where the file is being saved or change the 

location to another desired location. Keep the Save As type Microsoft Excel Workbook 

and click Save. 

e. After saving the backup file, on the File menu click File → click Save As a second time. 

f. In the Save as type: list, select CSV (Comma delimited) to add the .csv extension. 
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g. Click Save. 

h. When notified via a pop-up message that the file may contain features not compatible 

with CSV, click Yes to keep the workbook in the current format. 

i. Close the Excel file. 

i) When prompted, Do you want to save the changes made to the file? click No. 

 

Note: There will be 2 types of files at the end of these actions: the Excel .xls template and 

the .csv file. 

 

6. Upload the Demographics and Early Childhood.csv File via the IWAS/SIS/File Upload 

Screen 

a. Login to IWAS/SIS using an appropriate role for uploading files – RCDT/ADMIN role 

b. Access SIS from the System Listing. 

c. Click the Upload/Download File link in the Batch Files menu. 

d. Click Browse to locate the CSV Demographics and Early Childhood file created and 

saved in Steps 4 and 5 – (the name of the file should match the name entered in the 

Header Row 1 Column C). (Ex: Riverton.csv) 

e. Click Open and the Upload File page displays the selected file. 

f. Click the Upload button to complete the transmission to SIS. 

g. If you receive a message indicating your file has uploaded successfully, you are finished 

and should wait to receive an email indicating your file has processed and is ready to be 

downloaded. 

h. If you receive any file format errors during the upload process, you will want to go back 

to your Excel Template (.xls) version to make your changes and re-create a new CSV 

file. 

 

Note: Never make any changes in the CSV version or the formatting will be lost and will 

cause records to fail validation processes. 

 

7. Download the Returned Demographics and Early Childhood.csv File via the 

IWAS/SIS/File Download Screen 

a. Login to IWAS. 

b. Access SIS from the System Listing. 

c. Click the Upload/Download File link in the Batch Files menu. 

d. Locate the returned CSV Demographics and Early Childhood file uploaded in Step 6 – 

(the name of the file will match the name entered in the Header Row 1 Column C). (Ex: 

Riverton.csv) 

e. Save the file to your computer or server. 

 

Note: DO NOT OPEN THE FILE AND SAVE THE FILE WHILE IT IS OPEN. Save the 

file before opening in Excel with a right Click and perform ‘Save As’ or ‘Save Target As’. 

 

8. Retrieve and Paste Data from the Returned .csv File to the Existing Demographics and 

Early Childhood Template (.xls) 

a. Open the CSV file downloaded and saved to your computer / server in Step 7. 

b. Open the Demographics and Early Childhood Template (.xls). 
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c. Keep both the .csv file and the Excel template open. 

d. Highlight the cells in the Returned .csv file starting with Row 2 from Columns A through 

AX and all the additional rows from Columns A through AX that contain student data; 

DO NOT highlight the Result Codes and Result Messages in Columns AY and AZ. 

 

Note: It is important NOT to highlight beyond Column AX (in other words, do not 

highlight the result details, do not highlight blank space, do not highlight the entire row, 

do not highlight the row number on the far left). 

 

e. Select Edit → Copy 

f. Navigate to the Demographics and Early Childhood Excel Template. 

g. Click on the Row 3 Column A cell prior to pasting the data. 

h. Select Edit → Paste Special 

i. When the pop-up box opens, select Values then click Ok. 

j. Make any necessary corrections in the Demographics and Early Childhood Excel 

Template (.xls). 

 

9. Review the Result Codes and the Result Messages in Columns AY and AZ of the 

Returned .csv File, and if Corrections are Required Re-submit a New .csv File 

a. Utilizing the Demographics and Early Childhood Excel Template (.xls), make the 

necessary corrections to each student record that has the failed process Result Codes and 

Result Messages in Columns AY and AZ. (Please see the Result Code and Message table 

in either the User Manual or the File Format document for error descriptions.) 

 

Remember: Do Not make any changes in the CSV version or the formatting will be lost 

and will cause records to fail validation processes. 

 

b. Also, make changes if necessary to any identified inaccurate data, such as program 

indicators, grade levels, gender codes, etc. 

c. When all errors are resolved and all the changes are complete, create a new .csv file 

following the SAVE AS process in Step 5. 

d. Repeat this process until the records are returned with successful Result Codes and Result 

Messages. 


